WordPress公式プラグインリポジトリが対応PHPバージョンの表記に対応

SPONSORED LINK

WordPressはPHP5.2.4であれば動くように作られているが、プラグインの中にはそうでないものも多くある。たとえば筆者の作っている Gianism というプラグインはPHP5.4以上必須であるが、プラグインAPIに必要要件を指定する機能がないため、動作しているPHPのバージョンを調べ、5.4未満の場合にはなにもしないで警告を出すという処理を行なっている。

これまで、この「必要要件」に関する統一的なノウハウはなかったが、このたびMakeブログにおいて “Minimum PHP version requirement” という発表があった。readme.txtに以下のような記載をすると、PHPの必要バージョンが表示されるようになるのだ。

=== Plugin Name ===
Contributors: (this should be a list of wordpress.org userid's)
Donate link: http://example.com/
Tags: comments, spam
Requires at least: 4.6
Tested up to: 4.8
Requires PHP: 5.6
Stable tag: 4.3
License: GPLv2 or later
License URI: https://www.gnu.org/licenses/gpl-2.0.html

早速、Yoast などは対応済みである——といっても、PHP5.2.4に対応しているのだが。

なお、現在は「表示されるだけ」であり、インストールはできるようなので、よく確認せずにインストールするユーザーにとってはあまり意味はないかもしれない。

現在、別のチケットで「要件を満たさない場合はプラグインをインストールできないようにする」という課題が進行中であり、これもそのうち実装されることだろう。

SPONSORED LINK

この記事を書いた人

高橋 文樹

小説家であり、WordPress開発者。WordCamp Tokyo 2016のリードオーガナイザー。山梨に土地を持ち、DIYで家を建てている。小説と家づくりとWordPress開発の3種競技があれば日本代表有力候補。

この記事が気に入ったら
いいね!しよう

最新の情報をお届けします